
Project Development Roadmap 
 

 Note: In order to open the links, you must download and open the pdf file with a browser. 

Note: For database, you can either use SQL Server LocalDB if you use Windows and Visual Studio 

Community, or SQLite (https://www.sqlite.org/) if you use an operating system other than 

Windows, or SQL Server with Docker if you use an operating system other than Windows. 

 

1. Visual Studio Community installation for Windows: 

https://need4code.com/DotNet/Home/Index?path=.NET\00_Files\Visual%20Studio%20Commu

nity\Installation.pdf 

 

2. Rider for MAC: https://www.jetbrains.com/rider 

 

3. Docker Desktop installation for MAC: 

https://need4code.com/DotNet?path=.NET%5C00_Files%5CDocker%5CDocker%20Microsoft%2

0SQL%20Server.pdf 

4. The E-R Diagram of the project: 

 

https://www.sqlite.org/
https://need4code.com/DotNet/Home/Index?path=.NET/00_Files/Visual%20Studio%20Community/Installation.pdf
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https://www.jetbrains.com/rider
https://need4code.com/DotNet?path=.NET%5C00_Files%5CDocker%5CDocker%20Microsoft%20SQL%20Server.pdf
https://need4code.com/DotNet?path=.NET%5C00_Files%5CDocker%5CDocker%20Microsoft%20SQL%20Server.pdf


5. Create a .NET Aspire Empty App project. 

 

6. Give Solution name as your project name and if you want change the solution folder in Location, 

Create in new folder option must be checked. 

 

7. Select .NET 8.0 as the Framework, check Configure for HTTPS and select .NET Aspire version as 

8.2. 

 

8. In Solution Explorer create a new project called CORE under your solution, right click the 

Solution then Add -> New Project, then search for Class Library and select it, give the project 

name CORE then select .NET 8.0 as the Framework. 

 

9. Create the folders and classes under the CORE project as in: 

https://github.com/cagilalsac/PMS/tree/master/CORE 

 

You can right click on CORE project then Add -> New Folder to create a folder, 

you can right click on the folder then Add -> Class to create a new C# Class File with the 

extension .cs. 

 

The folder and file structure must be as below: 

APP\Domain\Entity.cs 

APP\Features\Handler.cs 

APP\Features\Request.cs 

APP\Features\QueryResponse.cs 

APP\Features\CommandResponse.cs 

 

10. Create a new project under your solution as Class Library and give the name Projects.APP. 

 

11. Create the Tag entity class under the Domain folder as in: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Domain/Tag.cs 

 

12. Create the ProjectsDb DbContext class under the Domain folder as in: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Domain/ProjectsDb.cs 

 

13. Right click on your Projects.APP project then Manage NuGet Packages, then from Browse tab 

search for Microsoft.EntityFrameworkCore.SqlServer package, select the latest version starting 

with 8 and install. 

 

14. If you want to use SQLite database instead of SQL Server LocalDB, right click on your 

Projects.APP project then Manage NuGet Packages, then from Browse tab search for  

System.Data.SQLite.Core package, select the latest version and install, then from the Browse tab 

search for Microsoft.EntityFrameworkCore.Sqlite package, select the latest version starting with 

8 and install. 

 

https://github.com/cagilalsac/PMS/tree/master/CORE
https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Domain/Tag.cs
https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Domain/ProjectsDb.cs


For data management with SQLite, you can click Extensions -> Manage Extensions from the 

Visual Studio menu, then search for “sqlite”, select the extension “SQLite and SQL Server 

Compact Toolbox” and install. You need to close Visual Studio for applying changes. 

 

After you run Visual Studio, from the Tools menu select “SQLite/SQL Server Compact Toolbox”. 

From the opened tab, select “Add SQLite Connection” from the top menu. From the opened 

window click “Browse” and select the SQLite database file “PMSProjectsDB” which is under your 

Projects.API folder.  After you close this window, you should see the database in the SQLite/SQL 

Server Compact Toolbox tab. 

 

15. Create a new project under the solution named Projects.API, search for web api and select 

ASP.NET Core Web API template, select .NET 8 as the Framework, Authentication type as None, 

check Configure for HTTPS, check Enable OpenAPI support, Use controllers and Enlist in .NET 

Aspire orchestration. 

 

16. Right click on Projects.API then Manage NuGet Packages, then from Browse tab search for 

Microsoft.EntityFrameworkCore.Tools package, select the latest version starting with 8 and 

install. Right click Projects.API in Solution Explorer then click Set as Startup Project. 

 

17. To create your database under SQL Server (localdb)\MSSQLLocalDB or SQLite database file, from 

Visual Studio menu, click Tools -> NuGet Package Manager -> Package Manager Console, select 

the project that has the DbContext, which is Projects.APP as the Default project, run “add-

migration v1” (v1 must be a unique name) in the console then after the operation is completed 

run “update-database”. 

 

 

For Rider you can use the UI for these operations as explained in: 

https://www.jetbrains.com/help/rider/Visual_interface_for_EF_Core_commands.html 

 

You can follow the sub topics such as Entity Framework Core: Add Migration and Entity 

Framework Core: Update Database. You must select the project which has the DbContext as 

explained in the Visual Studio database create operations above. 

 

18. You can see your created database under Visual Studio menu -> View -> SQL Server Object 

Explorer. Expand SQL Server then (localdb)\MSSQLLocalDB. Under Databases our database 

called PMSProjectsDB can be found. When necessarry, data can be viewed by right clicking the 

table under the database PMSProjectsDB then clicking View Data. Data can also be inserted, 

updated or deleted from this window. 

 

If you use SQLite database, you can find your database file under Projects.API. 

 

19. Right click on Projects.APP then Manage NuGet Packages, then from Browse tab search for  

MediatR package, select the latest version and install. 

 

https://www.jetbrains.com/help/rider/Visual_interface_for_EF_Core_commands.html


20. In Projects.APP, create a new folder named Features. Under Features create a new class called 

ProjectsDbHandler as in below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Features/ProjectsDbHandler.cs 

 

21. Under Features folder in Projects.APP, create a new folder named Tags and create the class 

TagQueryHandler under this folder as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Features/Tags/TagQueryHandler.

cs 

 

22. Then create the file containing TagCreateHandler and TagCreateRequest classes under 

Projects.APP -> Features -> Tags folder as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Features/Tags/TagCreateHandler

.cs 

 

23. Then create the file containing TagUpdateHandler and TagUpdateRequest classes under 

Projects.APP -> Features -> Tags folder as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Features/Tags/TagUpdateHandle

r.cs 

 

24. Then create the file containing TagDeleteHandler and TagDeleteRequest classes under 

Projects.APP -> Features -> Tags folder as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Features/Tags/TagDeleteHandler.

cs 

 

25. In Projects.API, open Program.cs to configure the Inversion of Control for the ProjectsDb and 

IMediator dependency injections as below in the IoC section: 

https://github.com/cagilalsac/PMS/blob/master/Projects.API/Program.cs 

 

26. Instead of using the connection string we defined in ProjectsDb class, we will use the connection 

string from our project’s configuration file which is appsettings.json. So open the ProjectsDb 

class and comment or delete the OnConfiguring method we overrode before as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Domain/ProjectsDb.cs 

Db classes inherited from the base DbContext class must have a constructor with a 

DbContextOptions instance parameter in order the use the connection string defined in 

appsettings.json. 

 

Then add the connection string to appsettings.json as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.API/appsettings.json 

 

27. In Projects.API, create an empty API Controller called TagsController then modify it as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.API/Controllers/TagsController.cs 

 

 

28. In Projects.APP, create the Project and ProjectTag entity classes under the Domain folder as in: 
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https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Domain/Project.cs 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Domain/ProjectTag.cs 

 

Also add the navigation property ProjectTags in the Tag entity: 
public List<ProjectTag> ProjectTags { get; set; } = new List<ProjectTag>(); 
 

29. In Projects.APP, add the Projects and ProjectTags DbSets in the ProjectsDb class in the Domain 

folder: 
public DbSet<Project> Projects { get; set; } 
public DbSet<ProjectTag> ProjectTags { get; set; } 
 

30. In Package Manager Console, select the project that has the DbContext (ProjectsDb), which is 

Projects.APP as the Default project, run “add-migration v2” in the console then after the 

operation is completed run “update-database” to add the Projects and ProjectTags tables to the 

database. 

 

31. In Projects.APP add ProjectQueryHandler class under the Features\Projects folder with 

ProjectQueryRequest and ProjectQueryResponse classes as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Features/Projects/ProjectQueryH

andler.cs 

 

32. In Projects.APP add ProjectCreateHandler class under the Features\Projects folder with 

ProjectCreateRequest class as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Features/Projects/ProjectCreate

Handler.cs 

 

33. In Projects.APP add ProjectUpdateHandler class under the Features\Projects folder with 

ProjectUpdateRequest class as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Features/Projects/ProjectUpdate

Handler.cs 

 

34. In Projects.APP add ProjectDeleteHandler class under the Features\Projects folder with 

ProjectDeleteRequest class as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Features/Projects/ProjectDelete

Handler.cs 

 

35. From now on we will use the Scaffolding Templates that the Scaffolding Mechanism of Visual 

Studio uses, which generates code for our API Controllers. In order to use these templates, go to  

https://need4code.com/DotNet/Home/Index?path=.NET\00_Files\Scaffolding%20Templates 

and extract the Templates folder inside the compressed Templates.7z file under your 

Projects.API folder. 

 

 

36. Right click the Controllers folder in your Projects.API, Add -> Controller. Then select API from the 

left menu, then API Controller with actions, using Entity Framework. Select Project entity as the 
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Model class, ProjectsDb for the DbContext class and give the Controller name 

ProjectsController. After the Scaffolding operation, your controller will be created as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.API/Controllers/ProjectsController.cs 

 

37. In Projects.APP add WorkQueryHandler class under the Features\Works folder with 

WorkQueryRequest and WorkQueryResponse classes as below:  

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Features/Works/WorkQueryHan

dler.cs 

 

38. In Projects.APP add WorkCreateHandler class under the Features\Works folder with 

WorkCreateRequest class as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Features/Works/WorkCreateHan

dler.cs 

 

39. In Projects.APP add WorkUpdateHandler class under the Features\Works folder with 

WorkUpdateRequest class as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Features/Works/WorkUpdateHa

ndler.cs 

 

40. In Projects.APP add WorkDeleteHandler class under the Features\Works folder with 

WorkDeleteRequest class as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/Features/Works/WorkDeleteHan

dler.cs 

 

41. Right click the Controllers folder in your Projects.API, Add -> Controller. Then select API from the 

left menu, then API Controller with actions, using Entity Framework. Select Work entity as the 

Model class, ProjectsDb for the DbContext class and give the Controller name WorksController. 

After the Scaffolding operation, your controller will be created as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.API/Controllers/WorksController.cs 

 

42. The steps above should be applied to create Users.APP and Users.API projects for entities 

User, Role, Skill and UserSkill. 

 

43. In Users.API open the appsettings.json file and add the AppSettings section as below: 

https://github.com/cagilalsac/PMS/blob/master/Users.API/appsettings.json 

 

44. In Users.APP create a class called AppSettings as below: 

https://github.com/cagilalsac/PMS/blob/master/Users.APP/AppSettings.cs 

 

45. Open the UsersDbHandler class in Users.APP\Features folder, then add CreateAccessToken and 

GetClaims methos as below: 

https://github.com/cagilalsac/PMS/blob/master/Users.APP/Features/UsersDbHandler.cs 
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46. In Users.APP, install the Microsoft.AspNetCore.Authentication.JwtBearer with the latest version 

starting with 8, and Microsoft.IdentityModel.Tokens with version 7.1.2 NuGet Packages. 

 

47. Create the class TokenHandler in Users.APP\Features\Users folder with TokenRequest and 

TokenResponse classes as below: 

https://github.com/cagilalsac/PMS/blob/master/Users.APP/Features/Users/TokenHandler.cs 

 

48. Open the Program.cs in Users.API and add the parts commented as APP SETTINGS, 

AUTHENTICATION and SWAGGER as below: 

https://github.com/cagilalsac/PMS/blob/master/Users.API/Program.cs 

 

49. In Users.API, open the UsersController in Controllers folder and add the Token and Authorize 

actions below: 

https://github.com/cagilalsac/PMS/blob/master/Users.API/Controllers/UsersController.cs 

 

Now you can get the JWT from the Token action and send the JWT starting with “Bearer” within 

any request’s Authorization header to the actions of the controllers. 

 

50. In the same controller, add [Authorize] attribute on top of the UsersController class therefore 

authorization, which will validate if the JWT exists within the request’s Authorization header, 

will be effective for all controller actions. 

 

Add [Authorize(Roles = “Admin”)] attribute to the Post, Put and Delete actions therefore 

authorization for Admin role, which will validate if the JWT exists and the containment of Role 

claim type with value Admin within the request’s Authorization header, will be effective only for 

these actions. 

 

Add [AllowAnonymous] attribute to Token and Authorize actions therefore the [Authorize] 

attribute of the UsersController class will be ineffective, and any request can be sent to these 

actions without applying authorization. 

 

51. Apply the Authorize attributes to the RolesController of Users.API as below: 

https://github.com/cagilalsac/PMS/blob/master/Users.API/Controllers/RolesController.cs 

 

52. Apply the Authorize attributes to the SkillsController of Users.API as below: 

https://github.com/cagilalsac/PMS/blob/master/Users.API/Controllers/SkillsController.cs 

 

 

53. In Projects.APP, install the Microsoft.IdentityModel.Tokens with version 7.1.2 NuGet Package 

then add AppSettings.cs file in the project folder as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.APP/AppSettings.cs 

 

54. In Projects.API, add AppSettings section to the appsettings.json file as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.API/appsettings.json 
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55. Open the Program.cs in Projects.API and add the parts commented as APP SETTINGS, 

AUTHENTICATION and SWAGGER as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.API/Program.cs 

 

56. Apply the Authorize attributes to the ProjectsController of Projects.API as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.API/Controllers/ProjectsController.cs 

 

57. Apply the Authorize attributes to the TagsController of Projects.API as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.API/Controllers/TagsController.cs 

 

58. Apply the Authorize attributes to the WorksController of Projects.API as below: 

https://github.com/cagilalsac/PMS/blob/master/Projects.API/Controllers/WorksController.cs 

 

59. In Users.APP, open the User entity under the Domain folder, and add the RefreshToken and 

RefreshTokenExpiration properties as below: 

https://github.com/cagilalsac/PMS/blob/master/Users.APP/Domain/User.cs 

 

Do not forget to add a new migration and update the database. 

 

60. In Users.APP, open the UsersDbHandler class under the Features folder and add the 

CreateRefreshToken method for random refresh token generation, and GetPrincipal method to 

reach the user claims principal including claims from a JWT as below: 

https://github.com/cagilalsac/PMS/blob/master/Users.APP/Features/UsersDbHandler.cs 

 

61. In Users.APP, open the TokenHandler class under the Features\Users folder and modify the 

response and handler classes as commented with REFRESH TOKEN as below: 

https://github.com/cagilalsac/PMS/blob/master/Users.APP/Features/Users/TokenHandler.cs 

 

Now you can get the JWT with refresh token in the response when you send a request to the 

Token action of the Users controller. 

 

 

62. In Users.APP, create the classes RefreshTokenRequest, RefreshTokenResponse and 

RefreshTokenHandler in the RefreshTokenHandler.cs file under the Features\Users folder as 

below for the generation of a new JWT and new refresh token when the existing JWT expires: 

https://github.com/cagilalsac/PMS/blob/master/Users.APP/Features/Users/RefreshTokenHandl

er.cs 

 

63. In Users.APP, add the property RefreshTokenExpirationInDays to the AppSettings class under 

the Users.APP project as below: 

https://github.com/cagilalsac/PMS/blob/master/Users.APP/AppSettings.cs 
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64. In Users.API, add the property RefreshTokenExpirationInDays to the appsettings.json file’s 

AppSettings section under the Users.API project as below: 

https://github.com/cagilalsac/PMS/blob/master/Users.API/appsettings.json 

 

65. In Users.API, open the UsersContoller under the Controllers folder and add the RefreshToken 

action as below: 

https://github.com/cagilalsac/PMS/blob/master/Users.API/Controllers/UsersController.cs 

 

Now you can get a new JWT with a new refresh token from this action when you send the 

existing JWT and existing refresh token request. 

 

66. Create a new project under the solution named Gateway.API, search for web api and select 

ASP.NET Core Web API template, select .NET 8 as the Framework, Authentication type as None, 

check Configure for HTTPS, do not check Enable OpenAPI support, do not check Use controllers 

and check Enlist in .NET Aspire orchestration. 

 

67. Right click on the Gateway.API project then click Manage NuGet Packages. Under the Browse 

tab search for Ocelot and install the latest version. 

 

68. After installation open the Program.cs file of the Gateway.API and modify as below: 

https://github.com/cagilalsac/PMS/blob/master/Gateway.API/Program.cs 

 

69. Add the file ocelot.json under the Gateway.API project and modify as below: 

https://github.com/cagilalsac/PMS/blob/master/Gateway.API/ocelot.json 

 

During modification, you can get the Host and Port of DownstreamHostAndPorts section from 

the launchSettings.json files which are under the Properties folder of Projects.API and Users.API. 

If you are running your solution with https, look for the https profile and use the first url defined 

at applicationUrl section which are for our solution https://localhost:7244 for Projects.API, and 

https://localhost:7279 for Users.API.  

If you are running your solution with http, look for the http profile and use the url defined at 

applicationUrl section which are for our solution http://localhost:5231 for Projects.API, and 

http://localhost:5292 for Users.API. 

 

Now you can reach all of the project and user endpoints defined in the ocelot.json file through 

this gateway. 

 

70. You can get the url of Gateway.API from the launchSettings.json file under the Properties folder 

which is for our solution, 

 

https: https://localhost:7212 (first url defined at applicationUrl of the https profile), 

http: http://localhost:5260 (url defined at applicationUrl of the http profile). 

 

Now you can send requests from your client application or Postman to the gateway url above. 

https://github.com/cagilalsac/PMS/blob/master/Users.API/appsettings.json
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Unfortunaltey, you can’t use Swagger to send requests to the gateway with this project 

configuration. 


